Search found 13 matches

by redion1992
Thu Jan 11, 2018 8:22 am
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

OK, that makes sense. I can see how it would be an issue on my setup :P Just tested gimx-config, and it seemed to auto-detect any clicks on the mouse buttons fine. It doesn't pick up any axis movements unless I select axis mode, which is probably as written. First thought to check was the "Multiple ...
by redion1992
Tue Jan 09, 2018 2:43 pm
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

Good to hear! I'm guessing the code was just barfing at the amount of devices I have connected regularly? Apart from having a steering wheel, there's an extra USB monitor, multiple Arduinos running serial outputs to displays, external hard drives, multiple gamepads and receivers... And that's not a ...
by redion1992
Tue Jan 09, 2018 10:21 am
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

Just tested it, and it works great! Started up fine. Thanks for your help on working this through!
by redion1992
Mon Jan 08, 2018 2:59 pm
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

That would certainly be the case. It's a computer that does a LOT of different things. I used USBDeview to produce a list of all 52 that are registered. 45 of them are currently listed as connected. Then there's four without drivers, and another eight USB hubs, hitting 64.
by redion1992
Mon Jan 08, 2018 5:31 am
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

Just tested it. Crashed again. I had to edit the drmemory.bat, as I don't have a user account named Matlo on my PC :P And it turns out that it doesn't like to run the x86 version of Dr. Memory on an x64 PC. It threw the following message: ~~Dr.M~~ Running on an unsupported operating system. Please d...
by redion1992
Sun Dec 31, 2017 1:46 pm
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

I have a bit of a hunch based on some experiments. Using some of the command line options for GIMX, I've found that it crashes when referring to a configuration XML. This also occurs when hitting Check in Gimx-launcher, and I'm assuming that when starting Gimx-config from the launcher it tries to au...
by redion1992
Sun Dec 31, 2017 10:29 am
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

OK, 7.0 beta logs: GIMX Console: src/windows/gprio.c:23 gprio: failed to set priority class GIMX logfile: global option -l with value `log.txt' global option -c with value `LogitechG27_G29.xml' controller #1: option -p with value `COM11' now reading arguments for controller #2 status flag is set sub...
by redion1992
Sun Dec 31, 2017 10:18 am
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

I'm finding I have to reboot between each attempt, otherwise something goes wrong and I keep getting an error from ProcDump after the first run. And unfortunatley, on that run just then, not only did GIMX crash, but so did ProcDump without capturing anything! Upgraded the installed version to 7.0 be...
by redion1992
Sun Dec 31, 2017 10:04 am
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

Just tested it again. This time, the only displayed text in the GIMX console window is: windows/gprio.c:23 gprio: failed to set priority class ProcDump gave the following output: Process: gimx.exe (3620) Process image: C:\Program Files\GIMX\gimx.exe CPU threshold: n/a Performance counter: n/a Commit...
by redion1992
Sat Dec 30, 2017 1:09 pm
Forum: Support
Topic: Gimx application Crashes
Replies: 32
Views: 1151

Re: Gimx application Crashes

Well, I just did a clean reinstall. Wiped everything on the SSD, and started from scratch... and I'm still having issues. I do wonder if some of the less common software I run could be causing an issue, most notably a thing called DrivePool (which basically acts as an overlay RAID on top of an NTFS ...