Page 1 of 1

English windows only?

Posted: Thu Aug 10, 2017 2:37 am
by aowji23ijod
I have question about a bug of the GIMX.

I would say that GIMX cannot handle 2 byte language device name.
I live in South Korea and I'm using Korean windows 7 64bit.
Therefore, device names of device managers in control panel are all Korean like this.



Changing system locale doesn't solve the problem.

When I use a default DS4 profile, it is ok because the name is in English.
In contrast, when I use an USB keyboard, it is NOT ok because the name is "HID 규격 사용자 컨트롤 장치" which is in Korean.

Will the guys of GIMX development department solve the issue soon, or should I install English windows for saving time?

Code: Select all

global option -l with value `log.txt'
global option -c with value `test.xml'
controller #1: option -p with value `\\?\hid#vid_2008&pid_0001#7&29ba506b&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}'
now reading arguments for controller #2
grab flag is unset
status flag is set
subpos flag is set
force_updates flag is set
window_events flag is set
GIMX 6.8 x86_64
Windows 7 SP1 x64
Kernel version: 6.1 (7601)
GPP detected, controller type is: DS4.
using default refresh period: 10.00ms
A device name is empty. Multiple mice and keyboards are not managed.
Warning: can't open macro directory C:\Users\MAIN\AppData\Roaming//gimx//macros/
Timer resolution: min=156001 max=5000 current=5000

Re: English windows only?

Posted: Thu Aug 10, 2017 9:45 pm
by Matlo
Thanks for reporting. I'll try to fix this, but won't be able to do it before next week.
As this is probably a Windows-specific issue, you may try running GIMX in Ubuntu 16.04 or Linux Mint 18.

Re: English windows only?

Posted: Thu Aug 17, 2017 9:40 pm
by Matlo
Please try this test version: ... x86_64.exe