Page 1 of 1

(Solved) Raspberry Pi 2 + Latest Raspian (Jan, 2016) and FFB

Posted: Mon Jan 18, 2016 1:48 pm
by sedilson
Hi community,

While my question is not related to GIMX, the problem I face is due to face to use of it and this is Game-pad specific community so the experience of the users can help me.

I have used GIMX in two modes, always using Dualshock 3/SixaxiS.

1) SixaxiS wired to Raspberry Pi and Raspberry Pi wireless to PS3

2) SixaxiS wireless to Raspberry Pi and Raspberry Pi connected to DIY (Arduino Board + CP2102) and DIY wired connected to PS3

Both ways GIMX works fine, but no FFB. That's my problem. The same setup for 2) but suing PC+Ubuntu 14.04-3, I got FFB

Using FFTEST tool to verify o have:

Code: Select all

$ cat /proc/bus/input/devices

I: Bus=0003 Vendor=054c Product=0268 Version=0111
N: Name="Sony PLAYSTATION(R)3 Controller"
P: Phys=usb-3f980000.usb-1.3/input0
S: Sysfs=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:054C:0268.0004/input/input2
U: Uniq=
H: Handlers=js0 event2
B: EV=1b
B: KEY=7 0 0 0 0 0 0 0 0 0 0 0 0 ffff 0 0 0 0 0 0 0 0 0
B: ABS=7fffff00 27
B: MSC=10

$ fftest /dev/input/event2
Force feedback test program.

Device /dev/input/event2 opened
Axes query:
Number of simultaneous effects: 0
Upload effects[0]: Function not implemented
Upload effects[1]: Function not implemented
Upload effects[2]: Function not implemented
Upload effects[3]: Function not implemented
Upload effects[4]: Function not implemented
Upload effects[5]: Function not implemented
Enter effect number, -1 to exit

Running the same tool on Ubuntu 14.04 o have effects 0, 4 and 5 as "ok". Testing any of them DS3 vibrates.

So the guidance I'm looking here is: Does anyone has Pi 2 running Raspbian (Jessie - November 2015 or Wheezy - May 2015) that can get FFB working on wired DS3 controller?


Re: Raspberry Pi 2 + Latest Raspian (Jan, 2016) and FFB

Posted: Tue Jan 19, 2016 6:39 pm
by Matlo

Which GIMX software and firmware version are you using?

Re: Raspberry Pi 2 + Latest Raspian (Jan, 2016) and FFB

Posted: Fri Jan 22, 2016 2:37 pm
by sedilson
Hi Matlo,

Tried 5.5 and 5.6, but it's not related to GIMX at all.

After extensive googling I could have FFB working.

The solution is described here: ... 23#p885523

Re: (Solved) Raspberry Pi 2 + Latest Raspian (Jan, 2016) and

Posted: Fri Jan 22, 2016 4:17 pm
by Matlo

When the device is used for authentication GIMX directly sends the FFB commands.
This is the case for:
  • a Dualshock 4 used with a PS4
  • an Xbox 360 controller used with an Xbox 360
  • an Xbox One controller used with an Xbox One
But in other cases GIMX uses the force feedback interface provided by the operating system.
It looks like the force feedback interface is missing on the RPi...