Problème d'installation de package (sur Raspberry)

La section où l'on parle français !
Post Reply
Bacara
Posts: 6
Joined: Wed May 13, 2015 1:52 pm

Problème d'installation de package (sur Raspberry)

Post by Bacara » Wed May 13, 2015 2:22 pm

Bonjour à tous,

je souhaite travailler le code de GE_Test sur une Raspberry Pi 2, en suivant sur ce tutoriel :
http://gimx.fr/wiki/index.php?title=Dev ... e_r1277.29

Lors que je lance cette requête :

Code: Select all

sudo apt-get install git g++ libwxgtk2.8-dev libbluetooth-dev libxml2-dev libusb-1.0-0-dev libncursesw5-dev gettext xterm xdg-utils libmhash-dev libcurl4-gnutls-dev libxi-dev libx11-dev libhidapi-dev libhidapi-hidraw0
je me retrouve avec ces erreurs :
E: Unable to locate package libhidapi-dev
E: Unable to locate package libhidapi-hidraw0

Je ne sais pas d'où cela peut venir. J'ai tenté de retoruver les packages via http://packages.ubuntu.com/ mais leur installation pose toujours problème.

Toutes les mises à jour ont bien été effecutés et je suis sous Raspbian.

Merci

User avatar
Matlo
Posts: 4890
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Problème d'installation de package (sur Raspberry)

Post by Matlo » Wed May 13, 2015 6:16 pm

Bonjour,

Effectivement la librairie hidapi n'est pas dispo pour Raspbian Wheezy.
Apparemment elle est dispo pour Raspbian Jessie, je suis en train de faire l'upgrade pour confirmer.
http://linuxconfig.org/raspbian-gnu-lin ... n-jessie-8

Sinon j'ai vu qu'il y a une image Raspbian Jessie optimisée pour le Rpi2, cela vaut peut-être le coup de regarder ça.
http://www.le-libriste.fr/2015/02/insta ... pberry-pi/
http://sjoerd.luon.net/posts/2015/02/de ... e-on-rpi2/
GIMX creator Donate Shop

User avatar
Matlo
Posts: 4890
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Problème d'installation de package (sur Raspberry)

Post by Matlo » Wed May 13, 2015 10:41 pm

Je confirme que hidapi est disponible pour Raspbian Jessie, par contre la mise à jour prend quelques heures.

Sinon il doit être possible d'installer manuellement les paquets suivants:
http://archive.raspbian.org/raspbian/po ... _armhf.deb
http://archive.raspbian.org/raspbian/po ... _armhf.deb

EDIT: libhidapi-dev dépend aussi de libhidapi-libusb0, qu'il faut aussi installer :
http://archive.raspbian.org/raspbian/po ... _armhf.deb
GIMX creator Donate Shop

Bacara
Posts: 6
Joined: Wed May 13, 2015 1:52 pm

Re: Problème d'installation de package (sur Raspberry)

Post by Bacara » Thu May 14, 2015 12:27 pm

Très bien, merci beaucoup pour toutes ces précisions. Cela va bien m'aider.

Bacara
Posts: 6
Joined: Wed May 13, 2015 1:52 pm

Re: Problème d'installation de package (sur Raspberry)

Post by Bacara » Fri May 15, 2015 8:36 am

J'ai tenté la deuxième méthode (installer les paquets manuellement), malheureusement le paquet libhidapi-hidraw0 dépend d'un autre paquet (libudev1).

Je me suis renseigné et apparement libudev1 n'est disponible que sur Jessie (je suis sur Wheezy).
N'y aurait-il pas un moyen d'installer le paquet manquant, sans migrer vers Jessie ? Il y a déjà quelques projets sur la Raspberry, j'ai peur que ça ne fonctionne plus une fois passé sur Jessie.

J'ai entendu parler de la cross-compilation, mais c'est une solution que je préfère éviter, je n'ai encore jamais fait cela. Je me dis que vous avez bien du utiliser cette solution pour adapter gimx à la raspberry.

User avatar
Matlo
Posts: 4890
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Problème d'installation de package (sur Raspberry)

Post by Matlo » Fri May 15, 2015 4:31 pm

J'ai construit les paquets pour la Wheezy, tu peux les récupérer ici : lien.
GIMX creator Donate Shop

Bacara
Posts: 6
Joined: Wed May 13, 2015 1:52 pm

Re: Problème d'installation de package (sur Raspberry)

Post by Bacara » Mon May 18, 2015 8:08 am

Cela marche parfaitement, merci pour votre aide.

Post Reply