Config tools not responding to key presses?

Talk about anything concerning the source code.
Post Reply
Tristan
Posts: 3
Joined: Tue Oct 04, 2016 9:54 pm

Config tools not responding to key presses?

Post by Tristan » Tue Oct 04, 2016 10:21 pm

So I've ordered the parts for my adapter and they're coming in tomorrow, I thought it'd be a good idea to get some configs set up in advance so I can get playing asap. For some reason the config tools refuse to acknowledge either keyboard or mouse inputs, it simply stays on the "Please press a button..." dialog. It's possible this has something to do with my Linux distro, I'm running Antergos ( Arch Linux ) and I've installed the 5.8 version of GIMX off of the AUR.

Thanks!

EDIT: So it looks like the window stops responding entirely after selecting one of the inputs. Trying to build 5.9 from git but there's issues with includes when I run make.

User avatar
Matlo
Posts: 4463
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Config tools not responding to key presses?

Post by Matlo » Wed Oct 05, 2016 2:45 pm

Moved the the development section as only distros based on Ubuntu 14.04 are supported.
You should try running gimx-config from the terminal, and see if any error message shows up.
GIMX creator Donate Shop

Tristan
Posts: 3
Joined: Tue Oct 04, 2016 9:54 pm

Re: Config tools not responding to key presses?

Post by Tristan » Thu Oct 06, 2016 1:50 am

So I ran it in terminal like you said and it seems that the issue was that it didn't have permission to access input devices, ran it with sudo and it worked like a charm :D

Edit: Here's a screenshot so you can see exactly what the problem was...
Image

User avatar
Matlo
Posts: 4463
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Config tools not responding to key presses?

Post by Matlo » Thu Oct 06, 2016 8:41 am

https://gimx.fr/wiki/index.php?title=De ... ermissions
This is handled in the postinst of the debian package.
GIMX creator Donate Shop

Post Reply