Development resources

Talk about anything concerning the source code.
cldfusion
Posts: 68
Joined: Fri Jul 08, 2011 4:02 pm

Re: Development resources

Post by cldfusion » Wed Dec 07, 2011 10:14 am

those were from ./install.sh

User avatar
Matlo
Posts: 4239
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Development resources

Post by Matlo » Wed Dec 07, 2011 10:32 am

Clearly not from install.sh.
Donate Shop

cldfusion
Posts: 68
Joined: Fri Jul 08, 2011 4:02 pm

Re: Development resources

Post by cldfusion » Thu Dec 08, 2011 10:07 am

:lol: it even has ./build.sh: infront, derp

Anyway, I ran Install.sh again and it appeared to work, but i had to unzip
libpthread-2.dll' then build.sh worked:), but i think my problem is with setting up eclipse cause it still can't find any of the inclusions.

User avatar
Matlo
Posts: 4239
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Development resources

Post by Matlo » Thu Dec 08, 2011 12:14 pm

In the latest mingw (20111118) the appropriate pthread dll is /mingw/bin/pthreadGC2.dll.
Donate Shop

cldfusion
Posts: 68
Joined: Fri Jul 08, 2011 4:02 pm

Re: Development resources

Post by cldfusion » Thu Dec 08, 2011 12:42 pm

I have that one in there, but when i ran build.sh it said it couldn't find libpthread-2.dll

User avatar
Matlo
Posts: 4239
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Development resources

Post by Matlo » Thu Dec 08, 2011 12:55 pm

The mingw version applicable for the wiki is 20110802.
Donate Shop

cldfusion
Posts: 68
Joined: Fri Jul 08, 2011 4:02 pm

Re: Development resources

Post by cldfusion » Sat Dec 10, 2011 6:10 am

Installed 20110802 and it all works fine now.
I still get errors in eclipse but it builds anyway.:)

User avatar
Zero
Posts: 68
Joined: Tue Aug 16, 2011 9:10 pm

Re: Development resources

Post by Zero » Sun Dec 11, 2011 12:21 pm

cldfusion wrote:Installed 20110802 and it all works fine now.
I still get errors in eclipse but it builds anyway.:)
That's because your missing includes. Project prop > C++ General > Paths and Sybols > add the proper libs > note that some paths have changed ... well at least on my version of libraries (latest Mingw/wx/..)
You don't really need them when compiling ... but its sure nice to have eclipse show errors.

Post Reply