Page 1 of 2

gimx 8,0

Posted: Tue Sep 29, 2020 7:40 pm
by ip_atlayan_dana
merhaba herkese iyi oyunlar.
gimx 8.0 firmware'i gimx e yükledikten sonra ilk açılışta baudrate ile alakalı hata almaya başladım... ilk gün bir sıkıntı yoktu ama ikinci gün baudrate hatası veriyor sonra başlıyor.. fakat oyunda herhangi bir problem olmamasına rağmen dualshock'u açık bırakıyor. daha önce böyle bir sorun yoktu. ve şuanda ilk launcher ı başlattığımda gimxteki firmware okunamadı hatası alıyorum.. onayladıktan sonra tekrar launcher ı tıklıyorum hata gelmeden açılıyor.. bunu sebebi nedir ? baudrate olayından nasıl kurtulabilirim ? dualshock açık kaldıktan sonrea gimx ten çıktığımda dualshock u kapatıyor..

Re: gimx 8,0

Posted: Wed Sep 30, 2020 4:40 am
by LoneWolf81

I am not Turkish but I will try to assist you using google translate.

Can you please add a log file to your post

Re: gimx 8,0

Posted: Wed Oct 07, 2020 3:10 pm
by ip_atlayan_dana
Hi LoneWolf81. I am sorry for my late answer.
When I first open the gimx launcher, it gives an error that the firmware type could not be read. I confirm the program is running. then it gives the error in the logs.

gimx works fine when playing ps4. but dualshock remains open due to these errors. hence it vibrates in cases such as changing the charger. this was not available in the old version. How can we solve this problem?

Ayarli Config Degeri -c `PS4_CallOfDutyModernWarfareRemastered_4773n0x.xml'
Kontroller #1: -p Baglanilan Port `COM3'
Simdi #2 Kontroller icin Bagimsiz Degiskenleri Okuyor
subpos Ayarlandi
Guncellemeleri Zorlama Ayarlandi
Otomatik Pencere Yakalama Ayarlandi
GIMX Adaptor Algilandi, Kontroller Tipi: DS4.
Firmware version: 8.0
Sifirlama Islemi GIMX Adaptore Gonderildi
Current baudrate: 500000 bps.
Trying baudrate: 2000000 bps.
src/windows/gserial.c:66 set_serial_params: SetCommState failed with error: Parametre hatalı.

Error: GIMX Adaptör Açılamadı
Error: failed to send data to the GIMX adapter
Trying baudrate: 1000000 bps.
Trying baudrate: 500000 bps.
Using baudrate: 500000 bps.
Gecis Cihazı Bulundu 0x054c:0x05c4
rounding timer period 1000us to 998us
registered joystick 0 with name "PS4 Controller"
Varsayilan Yenileme Suresini Kullanma: 10.00ms
Warning: Bir Cihaz Adi Bos. Birden Cok Fare ve Klavye Yonetilmez.
Haptic core has source haptic_source_rumble for device 054c:05c4
No haptic sink found for joystick 0 (PS4 Controller)
Rumble pass-through to joystick 0 (PS4 Controller)
Press the key/button assigned to PS.
rounding timer period 10000us to 9980us
Mouse frequency is 500Hz.

Re: gimx 8,0

Posted: Wed Oct 07, 2020 5:57 pm
by LoneWolf81
Is the console powered on when you start it as that can result in firmware type could not be read error. Can you test with another cable from adapter to the console and also re-flash the adapter.

Also can you paste a full log file on pastebin and link it here as there is no OS information that I can see.

Re: gimx 8,0

Posted: Thu Oct 08, 2020 3:03 pm
by ip_atlayan_dana
I changed the cable the problem persists. keeps getting errors. gimx works with these errors. no problem. i just keep getting these errors. I have repeatedly updated software on the adapter via the gimx launcher. but I keep getting the same error as result. Do I have to do it in a different way? If there is a different way can you tell me how to do it?

i use win 10 on pc. There was no problem in the previous version (v7.15). I got an update alert once and I updated the adapter. The first day I updated it did not show any errors. the second day i started getting these errors. i installed clean windows 10 as these are errors. but there is no change. Could there be a problem with gimx launcher, should I install it again?


Re: gimx 8,0

Posted: Thu Oct 08, 2020 3:17 pm
by LoneWolf81
Can you double check your UsbDk version that is currently installed it should be v1.00-22 if its not I will post a link so you can download it. If it is I would recommend you remove GIMX as well as USBDK and restart before installing the newest version again ... 22_x64.msi

If there is an older version remove it and restart your computer then install the new version and restart again.

Let me know the outcome.

Also can you tell me if your adapter was bought or self made and is it soldered and not using jumper cables.

Re: gimx 8,0

Posted: Fri Oct 09, 2020 3:15 pm
by ip_atlayan_dana
Hello. I deleted gimx twice and installed it again. but the result is the same. Couldn't read firmware type error when first started. I checked the USBDK version. I saw it was v1.00.22. After I deleted gimx from pc, I searched on regedit and deleted everything related to gimx. I reinstalled gimx. the result is the same. My friend made the adapter for me. I had no problems until the previous version. I could not see any problem with solder and wires.

Re: gimx 8,0

Posted: Fri Oct 09, 2020 5:38 pm
by LoneWolf81
Can you give me the chip numbers on the USB UART and AVR Board, have you tried to go back to the version that worked and see if the issue is resolved ?

Re: gimx 8,0

Posted: Sat Oct 10, 2020 7:57 pm
by ip_atlayan_dana
I don't know what tricks you are talking about, but I'm throwing a picture at you. By the way, I have no idea how to downgrade. Is there a place where I can get information about where it is done?

Re: gimx 8,0

Posted: Sun Oct 11, 2020 4:57 am
by LoneWolf81
You can just remove 8.0 and install 7.15 and load the firmware from version 7.15 ... x86_64.exe