Teensy++ is not recognized

Need help? Ask here and someone will help
Post Reply
Johnny
Posts: 7
Joined: Tue Dec 13, 2016 3:42 pm

Teensy++ is not recognized

Post by Johnny » Tue Dec 13, 2016 3:59 pm

Solved: The Teensy++ 2.0 needs to use the file AT90USB1286.hex as described in the reference of PJRC


Hi,

when I try to pair to a PS4 via bluetooth in the gimx-launcher tool in ubuntu 16.04 the tool fails to recognize that i plugged in the Teensy++ 2.0 and I don't know why. I did the following things and nothing helped:

I flashed the Teensy with the official Teensy flasher running with sudo in automatic mode by using the file atmega32u4.hex from the special firmware package and I also installed the udev teensy rules by putting the file 49-teensy.rules into /etc/udev/rules.d/.

The flashing console output is:

Code: Select all

Auto Button event
Auto mode: enabled
Device came online, code_size = 130048
Board is: Teensy++ 2.0 (AT90USB1286), version 1,20
File "atmega32u4.hex". 4108 bytes, 3% used
set background IMG_ONLINE
File "atmega32u4.hex". 4108 bytes, 3% used
Code size from .elf file = 0
begin operation
flash, block=0, bs=256, auto=1
flash, block=1, bs=256, auto=1
flash, block=2, bs=256, auto=1
flash, block=3, bs=256, auto=1
flash, block=4, bs=256, auto=1
flash, block=5, bs=256, auto=1
flash, block=6, bs=256, auto=1
flash, block=7, bs=256, auto=1
flash, block=8, bs=256, auto=1
flash, block=9, bs=256, auto=1
flash, block=10, bs=256, auto=1
flash, block=11, bs=256, auto=1
flash, block=12, bs=256, auto=1
flash, block=13, bs=256, auto=1
flash, block=14, bs=256, auto=1
flash, block=15, bs=256, auto=1
flash, block=16, bs=256, auto=1
sending reboot
begin wait_until_offline
HID/linux: something changed, try reading a descriptor
HID/linux: Device was just disconnected
offline, waited 5
end operation
set background IMG_REBOOT_OK
redraw timer set, image 14 to show for 1200 ms
redraw, image 9
Running dmesg -w while unplugging and plugging in again the Teensy brings this:

Code: Select all

[ 2241.719952] usb 1-1.3: new full-speed USB device number 85 using ehci-pci
[ 2241.807918] usb 1-1.3: device descriptor read/64, error -32
[ 2241.999865] usb 1-1.3: device descriptor read/64, error -32
[ 2242.175919] usb 1-1.3: new full-speed USB device number 86 using ehci-pci
[ 2242.263899] usb 1-1.3: device descriptor read/64, error -32
[ 2242.455905] usb 1-1.3: device descriptor read/64, error -32
[ 2242.631933] usb 1-1.3: new full-speed USB device number 87 using ehci-pci
[ 2243.039912] usb 1-1.3: device not accepting address 87, error -32
[ 2243.111922] usb 1-1.3: new full-speed USB device number 88 using ehci-pci
[ 2243.519855] usb 1-1.3: device not accepting address 88, error -32
[ 2243.519997] usb 1-1-port3: unable to enumerate USB device

I ran gimx-launcher as gksudo -k -u root. I updated everything and freshly installed everything. Nothing helped.

Post Reply