Wheel not working with some PS4 games

Need help? Ask here and someone will help
User avatar
kaiba_seto2004
Posts: 317
Joined: Sat Jul 15, 2017 9:15 am

Re: Wheel not working with some PS4 games

Post by kaiba_seto2004 » Sat Jan 05, 2019 4:10 am

I don't see any problems when we say we need log time.
This is just like a doctor can't find problems unless his patient provides medical record.
PS4 enthusiast.

jabidin
Posts: 26
Joined: Thu Dec 27, 2018 3:14 pm

Re: Wheel not working with some PS4 games

Post by jabidin » Sat Jan 05, 2019 11:09 am

kaiba_seto2004 wrote:
Sat Jan 05, 2019 4:10 am
I don't see any problems when we say we need log time.
This is just like a doctor can't find problems unless his patient provides medical record.
Errors:

Code: Select all

src/libusb/gusbhid.c:453 claim_device: libusb_open failed with error: Access denied (insufficient permissions)
/usr/bin/xdg-open: 709: /usr/bin/xdg-open: : Permission denied
global option -l with value `log.txt'
global option -c with value `LogitechDrivingForce_G29.xml'
controller #1: option -p with value `/dev/ttyUSB0'
now reading arguments for controller #2
status flag is set
subpos flag is set
force_updates flag is set
auto-grab flag is set
GIMX 7.9 ARMv6
Raspbian GNU/Linux 9.4 (stretch)
Linux 4.1.21-v7+ #873 SMP Mon Apr 11 18:22:10 BST 2016 unknown
Bus 001 Device 006: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 005: ID 054c:09cc Sony Corp.
Bus 001 Device 007: ID 046d:c298 Logitech, Inc. Driving Force Pro
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
        |__ Port 2: Dev 7, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 5, If 0, Class=Audio, Driver=usbfs, 12M
        |__ Port 3: Dev 5, If 1, Class=Audio, Driver=usbfs, 12M
        |__ Port 3: Dev 5, If 2, Class=Audio, Driver=usbfs, 12M
        |__ Port 3: Dev 5, If 3, Class=Human Interface Device, Driver=usbfs, 12M
        |__ Port 5: Dev 6, If 0, Class=Vendor Specific Class, Driver=cp210x, 12M
GIMX adapter detected, controller type is: G29 PS4.
Reset sent to the GIMX adapter.
found pass-through device 0x054c:0x09cc
registered joystick 0 with name "Sony Computer Entertainment Wireless Controller"
using default refresh period: 5.00ms
native mode is already enabled for HID device 01:01:02:00:00 (PID=c298)
joystick 0 has name 'Sony Computer Entertainment Wireless Controller' and virtual id 0
joystick 1 has name 'Logitech Logitech Driving Force Pro' and virtual id 0
Dump of /home/pi/.gimx/config/LogitechDrivingForce_G29.xml:
<?xml version="1.0" encoding="UTF-8"?>
<root>
https://pastebin.com/GDp9FvfE

User avatar
GoDlike
Posts: 794
Joined: Thu Apr 28, 2016 12:47 pm
Location: Poland

Re: Wheel not working with some PS4 games

Post by GoDlike » Sat Jan 05, 2019 1:33 pm

You are still using invalid config and Matlo already told you that. You should use config for Driving Force Pro - LogitechDrivingForcePro_G29.xml yet you use the one for Driving Force.
My hardware: PS3 Slim CFW 4.80 | PS4 Pro 500 Million LE | Xbox One S
Steam: Godlike_RU | PSN: GoDlike_RU | XBL: GoDlike

jabidin
Posts: 26
Joined: Thu Dec 27, 2018 3:14 pm

Re: Wheel not working with some PS4 games

Post by jabidin » Sat Jan 05, 2019 2:17 pm

GoDlike wrote:
Sat Jan 05, 2019 1:33 pm
You are still using invalid config and Matlo already told you that. You should use config for Driving Force Pro - LogitechDrivingForcePro_G29.xml yet you use the one for Driving Force.
It does not start with the - LogitechDrivingForcePro_G29.xml -; Always with - LogitechDrivingForce_G29.xml; I have to change it manually;
but there are mistakes too:

Code: Select all

src/libusb/gusbhid.c:453 claim_device: libusb_open failed with error: Access denied (insufficient permissions)
/usr/bin/xdg-open: 709: /usr/bin/xdg-open: : Permission denied
global option -l with value `log.txt'
global option -c with value `LogitechDrivingForcePro_G29.xml'
controller #1: option -p with value `/dev/ttyUSB0'
now reading arguments for controller #2
status flag is set
subpos flag is set
force_updates flag is set
auto-grab flag is set
GIMX 7.9 ARMv6
Raspbian GNU/Linux 9.4 (stretch)
Linux 4.1.21-v7+ #873 SMP Mon Apr 11 18:22:10 BST 2016 unknown
Bus 001 Device 006: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 005: ID 054c:09cc Sony Corp.
Bus 001 Device 007: ID 046d:c298 Logitech, Inc. Driving Force Pro
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
        |__ Port 2: Dev 7, If 0, Class=Human Interface Device, Driver=usbfs, 1.5M
        |__ Port 3: Dev 5, If 0, Class=Audio, Driver=usbfs, 12M
        |__ Port 3: Dev 5, If 1, Class=Audio, Driver=usbfs, 12M
        |__ Port 3: Dev 5, If 2, Class=Audio, Driver=usbfs, 12M
        |__ Port 3: Dev 5, If 3, Class=Human Interface Device, Driver=usbfs, 12M
        |__ Port 5: Dev 6, If 0, Class=Vendor Specific Class, Driver=cp210x, 12M
GIMX adapter detected, controller type is: G29 PS4.
Reset sent to the GIMX adapter.
found pass-through device 0x054c:0x09cc
registered joystick 0 with name "Sony Computer Entertainment Wireless Controller"
using default refresh period: 5.00ms
native mode is already enabled for HID device 01:01:02:00:00 (PID=c298)
src/libusb/gusbhid.c:497 claim_device: libusb_claim_interface failed with error: Resource busy
joystick 0 has name 'Sony Computer Entertainment Wireless Controller' and virtual id 0
joystick 1 has name 'Logitech Logitech Driving Force Pro' and virtual id 0
Dump of /home/pi/.gimx/config/LogitechDrivingForcePro_G29.xml:
<?xml version="1.0" encoding="UTF-8"?>
<root>
  <controller id="1" dpi="0" type="G29 PS4">
    <configuration id="1">
      <trigger type="" id="" name="" button_id="" switch_back="no" delay="0"/>
      <mouse_options_list/>
      <intensity_list/>
      <button_map>
        <button id="abs_axis_3" label="">
          <device type="joystick" id="0" name="Logitech Logitech Driving Force Pro"/>
          <event type="button" id="14"/>
        </button>
        <button id="abs_axis_6" label="">
          <device type="joystick" id="0" name="Logitech Logitech Driving Force Pro"/>
          <event type="button" id="17"/>
        </button>
        <button id="abs_axis_4" label="">
          <device type="joystick" id="0" name="Logitech Logitech Driving Force Pro"/>
          <event type="button" id="15"/>
        </button>
        <button id="abs_axis_5" label="">
          <device type="joystick" id="0" name="Logitech Logitech Driving Force Pro"/>
https://pastebin.com/K1Swi9Vq

User avatar
Matlo
Posts: 5324
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: Wheel not working with some PS4 games

Post by Matlo » Sun Jan 06, 2019 7:52 pm

Just click on "Help > Download config" in gimx-launcher, and download the right configuration.
Then make another log file, and make sure to stop GIMX before retrieving the log file.
GIMX creator Donate Shop

jabidin
Posts: 26
Joined: Thu Dec 27, 2018 3:14 pm

Re: Wheel not working with some PS4 games

Post by jabidin » Sun Jan 06, 2019 10:23 pm

Matlo wrote:
Sun Jan 06, 2019 7:52 pm
Just click on "Help > Download config" in gimx-launcher, and download the right configuration.
Then make another log file, and make sure to stop GIMX before retrieving the log file.
ok

Post Reply