"A device attached to the system is not functioning"

Need help? Ask here and someone will help
Post Reply
Posts: 4
Joined: Sun Dec 01, 2019 5:11 pm

"A device attached to the system is not functioning"

Post by ultsse »

EDIT: Issue resolved! The issue was down to the over-exposed wires. I suppose the driver errors were caused with random contacts between the wires, or there was some other unknown issue with my soldering. I resoldered the wires and cleaned up the boards, and it now works perfectly :)

Recently I tried making my own adapter, but was at a flaw due to me not having a soldering iron. I got it working but recently one of the pins on my USB to TTL convertor broke, so I went out and bought a soldering iron to solder the wires onto the boards directly. I did that, but now my GIMX randomly crashes without displaying any error, and Windows' Device Manager says the convertor's driver failed to start with error code 10 (pic attached). Any suggestions on what to do? No idea what the problem could be.

Error Log: https://pastebin.com/byD71ZZE
Error in Device Manager: https://camilla.is-a-good-waifu.com/8zHajnx.png
Wire Configurations:
- Arduino: https://cdn.discordapp.com/attachments/ ... 223610.jpg
- USB to TTL convertor (CP2102): https://cdn.discordapp.com/attachments/ ... 223607.jpg
- Arduino: https://www.amazon.co.uk/gp/product/B07 ... UTF8&psc=1
- USB to TTL convertor (CP2102): https://www.amazon.co.uk/gp/product/B07 ... UTF8&psc=1
Firmware: Latest (flashed via gimx-launcher), EMUPS4
Target Console: PS4
Game: Borderlands 3
Input Method: Keyboard + Mouse

EDIT: whoops, forgot to attach error in device manager pic

User avatar
Posts: 5693
Joined: Wed Jul 06, 2011 7:01 am
Location: France

Re: "A device attached to the system is not functioning"

Post by Matlo »

I'm glad you fixed it. The solder wire seems to be of poor quality. You may achieve much better soldering getting suitable solder wire in an electronic shop.
GIMX creator Donate Shop

Post Reply