GIMX 6.11

Updates and News about GIMX
Post Reply
User avatar
Matlo
Posts: 4513
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

GIMX 6.11

Post by Matlo » Wed Nov 15, 2017 7:51 pm

Enhancements:
  • On Windows, the setup now automatically installs UsbDk and the cp210x drivers.
  • In gimx-config, the "G27 PS3" controller type was renamed "G27 PS3 / PC".
  • In gimx-launcher, The "DIY USB" output type was renamed "GIMX adapter".
Bug fix:
  • The i386 setup now properly installs the Arduino drivers on Windows 64-bit.
  • The +/-, enter, dial up/down buttons of the G29 emulation are no more exclusive/conflicting.
Fixed issues.

Software download.
Firmware download.

Please report issues here: link.

Known issues
GIMX creator Donate Shop

sephirotdnf
Posts: 61
Joined: Sat Feb 23, 2013 4:11 pm

Re: GIMX 6.11

Post by sephirotdnf » Tue Nov 21, 2017 9:29 am

Hello Matlo,
Raspbian software and firmware up to date.

gimx : Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
libwxbase3.0-0v5 is already the newest version (3.0.2+dfsg-4).

Any ideas?

Code: Select all

pi@Malina:~ $ sudo dpkg -i gimx.deb
(Reading database ... 126169 files and directories currently installed.)
Preparing to unpack gimx.deb ...
Unpacking gimx (6.11-1) over (6.11-1) ...
dpkg: dependency problems prevent configuration of gimx:
 gimx depends on libwxbase3.0-0 (>= 3.0.2); however:
  Package libwxbase3.0-0 is not installed.
 gimx depends on libwxgtk3.0-0 (>= 3.0.2); however:
  Package libwxgtk3.0-0 is not installed.
 gimx depends on avrdude; however:
  Package avrdude is not installed.

dpkg: error processing package gimx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
 gimx
pi@Malina:~ $ sudo apt-get update && sudo apt-get upgrade
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:3 https://dev2day.de/pms stretch InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gimx : Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
        Depends: libwxgtk3.0-0 (>= 3.0.2) but it is not installable
        Depends: avrdude but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
pi@Malina:~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  gimx
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 1,803 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 126169 files and directories currently installed.)
Removing gimx (6.11-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
pi@Malina:~ $

sephirotdnf
Posts: 61
Joined: Sat Feb 23, 2013 4:11 pm

Re: GIMX 6.11

Post by sephirotdnf » Tue Nov 21, 2017 9:37 am

It seems either link or wiki has to be updated for Scratch.

wget https://gimx.fr/download/gimx-raspbian -O gimx.deb
replaced with:
wget https://github.com/matlo/GIMX/releases/ ... tretch.deb -O gimx.deb
Installation Worked.

User avatar
Matlo
Posts: 4513
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: GIMX 6.11

Post by Matlo » Wed Nov 22, 2017 2:19 pm

Debian stretch is not officially supported. I'm providing a package for testing purposes.
GIMX creator Donate Shop

Post Reply