GIMX PC Issue

Need help? Ask here and someone will help
Sarge
Posts: 4
Joined: Wed Sep 27, 2017 4:17 am

GIMX PC Issue

Post by Sarge » Wed Sep 27, 2017 4:24 am

Hello All,

Just wondering if anyone has a suggestion for an issue I'm having connecting to my PC.

Bit of information;
I have GIMX installed on a Raspberry PI 3 (model B), using Raspbian. The adaptor is home made and loaded with the G27PC firmware.

Everything seems to work fine until a game is launched. In windows 10 it shows my Accuforce as a Logitech G27. In Windows all the buttons and pedals work just fine, but when I launch a game to play such as Forza or WRC on pc, only the dpad works. Not sure why this would be since everything works fine on the controller properties page.

Any suggestions welcome :)

Cheers,

Sarge

User avatar
Matlo
Posts: 4463
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: GIMX PC Issue

Post by Matlo » Wed Sep 27, 2017 7:34 am

Hi,

I moved your post to the support section.
Please add the details requested here: viewtopic.php?f=5&t=691
GIMX creator Donate Shop

Sarge
Posts: 4
Joined: Wed Sep 27, 2017 4:17 am

Re: GIMX PC Issue

Post by Sarge » Wed Sep 27, 2017 6:12 pm

Further information;

Log File: https://pastebin.com/9EQAMKk2

Connection Method: USB (Homemade)
---Parts used: Wingoneer USB 2.0 to TTL UART 6pin Module CP2102, KOOKYE Pro Micro ATmega32U4

Firmware Version: Installed via GIMX firmware loader option, G27PC, not sure which hex because it did it automatically. (Bit of a newbie to using these boards)

Gaming Target: PC
Games tried: WRC7, Forza Horizon 3, Forza Apex, Dirt 3
Controller: Simxperience Accuforce V2

User avatar
Matlo
Posts: 4463
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: GIMX PC Issue

Post by Matlo » Wed Sep 27, 2017 7:21 pm

Sadly recent Linux kernels are not stable on RPi.
You may try using an older one: https://gimx.fr/wiki/index.php?title=RP ... are_update

Also note that running GIMX on the PC itself should work.
GIMX creator Donate Shop

Sarge
Posts: 4
Joined: Wed Sep 27, 2017 4:17 am

Re: GIMX PC Issue

Post by Sarge » Wed Sep 27, 2017 8:16 pm

Thanks for the help.

I tried reverting back to the firmware that was recommended on the wiki but encountered identical results with exception to the wheel commands showing in the log file. The wheel kind of works but there is no ffb, no start button, and Logitech Profiler does not see any devices connected.

I have also tried to run GIMX from the PC and still get the same results as I did with the Raspberry Pi apart from being unable to view the wheel properties.

Not really sure what else I could try since windows itself shows the wheel to be working.

Sarge
Posts: 4
Joined: Wed Sep 27, 2017 4:17 am

Re: GIMX PC Issue

Post by Sarge » Thu Sep 28, 2017 12:12 am

Finally found the problem. Turns out that only the old Logitech drivers work for me. Once I sorted that out, I scrapped the RPi route and just hooked the GIMX adapter to my PC as was suggested earlier. I didn't realise you could use GIMX without a second PC or Pi. Doing that has fixed the scratchy force feedback I was getting while connected to the RPi. Everything seemingly works now, but needs some work in sim commander 4 to get the accuforce to play nice. However, it's a start! Thanks again for the help/pointers. :D

User avatar
Matlo
Posts: 4463
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: GIMX PC Issue

Post by Matlo » Thu Sep 28, 2017 5:57 am

The RPi route is not straightforward, and since it is a GNU/Linux platform it only supports force feedback for Logitech wheels. Direct drive wheels are only supported on Windows yet.
There are some details about force feedback support here: https://gimx.fr/wiki/index.php?title=Force_Feedback
GIMX creator Donate Shop

dumbunny360
Posts: 4
Joined: Sun Oct 15, 2017 10:36 am

Re: GIMX PC Issue

Post by dumbunny360 » Sun Oct 15, 2017 11:19 am

I am having the same problem as Sarge. I have downloaded the gimx software and loaded the driver for the usb board. I am using the usb adapter purchased on the webstore. I am trying to simulate a g25/g27 on the pc for pc gaming. how do I wire and config this? do I plug both ends of the adapter into the pc? I have read the wiki,but I can not find the answers i need. Are there any step by step instructions on how to get this working on the pc? Please help.

User avatar
Matlo
Posts: 4463
Joined: Wed Jul 06, 2011 7:01 am
Location: France
Contact:

Re: GIMX PC Issue

Post by Matlo » Sun Oct 15, 2017 1:09 pm

You have to load the EMUG27PC firmware: in gimx-launcher, click on "Help>Upgrade firmware" and follow the instructions to the letter.
And yes, you have to plug both ends into the PC, which will be used as both source and target in your case.
GIMX creator Donate Shop

dumbunny360
Posts: 4
Joined: Sun Oct 15, 2017 10:36 am

Re: GIMX PC Issue

Post by dumbunny360 » Sun Oct 15, 2017 6:14 pm

I loaded that firmware. When I completed the update I got an error "no new device found within 10 seconds" How do I get this to work?

Post Reply